26. Algoritmos || Ejercicios estructuras repetitivas Pseint


Ejercicios algoritmos Pseint






26. Hacer un algoritmo en Pseint para calcular el resto y cociente por medio de restas sucesivas.

Algoritmo Division_RestasSucesivas
 Definir n,d,resto,conta Como Entero;
 resto <- 0; conta <- 0;
 Escribir 'Numerador';
 Leer n;
 Escribir 'Denominador';
 Leer d;
 Repetir
  n <- n-d;
  resto <- n;
  conta <- conta+1;
 Hasta Que n<d
 Escribir 'El resto es: ',resto;
 Escribir 'El cociente es: ',conta;
FinAlgoritmo


Diagrama de flujo




Diagrama Nassi-Shneiderman





27. Hacer un algoritmo en Pseint para determinar la media de una lista indefinida de números positivos, se debe acabar el programa al ingresar un número positivo.

Algoritmo Suma_Numeros
 Definir n,media,conta Como Entero;
 Definir i Como Real;
 Escribir 'Ingrese un número';
 Leer n;
 media <- 0; conta <- 0; i <- 0;
 Mientras (n>=0) Hacer // El valor centinela es un número menor que cero
  media <- media+n;
  conta <- conta+1;
  Leer n; // mientra n sea mayorr que cero, el bucle continua     
 FinMientras
 i <- media/conta;
 Escribir 'La media es: ',i;
FinAlgoritmo


Diagrama de flujo




Diagrama Nassi-Shneiderman





28. Hacer un algoritmo en Pseint para calcular la suma de los primeros cien números con un ciclo repetir.

Algoritmo Suma_Numeros_Repetir
 Definir suma,conta Como Entero;
 conta <- 0; suma <- 0;
 Repetir
  conta <- conta+1;
  suma <- suma+conta;
 Hasta Que conta=100
 Escribir 'La suma es: ',suma;
FinAlgoritmo


Diagrama de flujo




Diagrama Nassi-Shneiderman





29. Hacer un algoritmo en Pseint para calcular la suma de los primeros cien números con un ciclo mientras.

Algoritmo Suma_Numeros_Mientras
 Definir suma,conta Como Entero;
 conta <- 0; suma <- 0;
 Mientras (conta<100) Hacer
  conta <- conta+1;
  suma <- suma+conta;
 FinMientras
 Escribir 'La suma es: ',suma;
FinAlgoritmo
Diagrama de flujo
Diagrama Nassi-Shneiderman
30. Hacer un algoritmo en Pseint para calcular la suma de los primeros cien números con un ciclo para.
Algoritmo Suma_Numeros_Para
 Definir suma,i Como Entero;
 suma <- 0;
 Para i<-1 Hasta 100 Hacer
  suma <- suma+i;
 FinPara
 Escribir 'La suma es: ',suma;
FinAlgoritmo
Diagrama de flujo
Diagrama Nassi-Shneiderman


7 comentarios:

  1. MUCHISIMAS GRACIAS AMIGO BENDICIONES Y EXITOOOOS

    ResponderEliminar
  2. Hola! Tengo que resolver el siguiente ejercicio en pseint y pasarlo a c: Se realiza un censo en un edificio, que tiene 10 departamentos.
    De cada departamento se ingresa la cantidad de personas mayores de edad y la cantidad de personas menores de edad que viven en el mismo (se ingresa un 0 si el departamento está desocupado).
    Al finalizar la carga de datos, el programa debe informar:
    - El total de personas que viven en el edificio.
    - Si viven más personas mayores o más personas menores y cuántos son.
    Mensajes:
    "En el edificio viven X personas".
    “Viven más personas mayores y son Z” o “Viven más personas menores y son Y”.
    Desde ya muchas gracias.

    ResponderEliminar
    Respuestas
    1. hola mi hermano al parecer ya lo hice tal vez tarde pero me sirve de practica !!

      Proceso sin_titulo
      Definir i,departamento,sumaMayor,mayores,menores,totalP,sumaT,sumaMenor Como Entero;
      Definir contadorMayor,contadorMenor Como Entero;
      sumaT <- 0;
      sumaMayor <- 0;
      sumaMenor <- 0;
      contadorMayor <- 0;
      contadorMenor <- 0;
      Para i<-1 Hasta 10 Hacer
      Escribir '**************************************';
      Escribir 'El departamento ',i,' esta ocupado';
      Escribir '1. Si';
      Escribir '2. No';
      Leer departamento;
      Segun departamento Hacer
      1:
      Escribir 'Ingrese la cantidad de personas mayores de edad';
      Leer mayores;
      Escribir 'Ingrese la cantidad de personas menores de edad';
      Leer menores;
      totalP <- mayores+menores;
      Escribir 'El departamento ',i,' Tiene ',totalP,' personas';
      sumaT <- sumaT+totalP;
      sumaMayor <- sumaMayor+mayores;
      sumaMenor <- sumaMenor+menores;
      Si sumaMayor>sumaMenor Entonces
      contadorMayor <- contadorMayor+1;
      SiNo
      contadorMenor <- contadorMenor+1;
      FinSi
      Escribir '*************************************';
      FinSegun
      FinPara
      Escribir '';
      Escribir 'Resumen del censo';
      Escribir '************************************';
      Escribir 'En el edificio viven ',sumaT,' personas';
      Si contadorMayor>contadorMenor Entonces
      Escribir '*******************************';
      Escribir 'En el edificio viven mas personas mayores';
      Escribir 'Con un total de ',sumaMayor,' personas mayores';
      SiNo
      Escribir '*******************************';
      Escribir 'En el edificio viven mas personas menores';
      Escribir 'Con un total de ',sumaMenor,' personas menores';
      FinSi
      FinProceso

      Eliminar
    2. Y que tal sería esta solución:
      Algoritmo contarPersonasApto
      Definir pMay, pMen, totalH,tMay,tMen Como Entero
      para i=1 hasta 10 Con Paso 1 hacer
      Escribir "Cantidad de peronas mayores de edad en en Apto ",i
      leer pMay
      Escribir "Cantidad de peronas menores de edad en en Apto ",i
      leer pMen
      tMay=tMay+pMay
      tMen=tMen+pMen
      FinPara
      Escribir "En el edificio hay un total de ",(tMay+tMen), " personas"
      Escribir "Hay un total de ",tMay," personas mayores de edad"
      Escribir "Hay un total de ",tMen," personas menores de edad"
      FinAlgoritmo

      Eliminar
  3. Me faltó indicar que había en mayor cantidad
    Algoritmo contarPersonasApto
    Definir pMay, pMen, totalH,tMay,tMen Como Entero
    para i=1 hasta 10 Con Paso 1 hacer
    Escribir "Cantidad de peronas mayores de edad en en Apto ",i
    leer pMay
    Escribir "Cantidad de peronas menores de edad en en Apto ",i
    leer pMen
    tMay=tMay+pMay
    tMen=tMen+pMen
    FinPara
    Escribir "En el edificio hay un total de ",(tMay+tMen), " personas"
    si tMay > tMen Entonces
    Escribir "Viven más personas mayores de edad que menores de edad"
    Escribir "Hay un total de ",tMay," personas mayores de edad"
    SiNo
    Escribir "Viven más personas mayores de edad que menores de edad"
    Escribir "Hay un total de ",tMen," personas menores de edad"
    FinSi
    FinAlgoritmo

    ResponderEliminar
  4. Hola tengo que resolver este ejercicio con repetir -hasta
    Contar cuantos números menores a 10 son ingresados antes de terminar el programa,el cual finaliza al momento de ingresar un número mayor a 10

    ResponderEliminar