16. Algoritmos || Ejercicios estructuras selectivas Pseint


Ejercicios algoritmos Pseint






16. Hacer un algoritmo en Pseint que lea un número y según ese número, indique el día que corresponde.

Proceso diaSemana
 Definir dia Como Entero;
 
 Escribir "Ingrese un día";
 Leer dia;
 
 si (dia = 1) Entonces
  Escribir "Lunes";
 SiNo
  si (dia = 2) Entonces
   Escribir "Martes";
  SiNo
   si (dia = 3) Entonces
    Escribir "Miércoles";
   SiNo
    si (dia = 4) Entonces
     Escribir "Jueves";
    SiNo
     si (dia = 5) Entonces
      Escribir "Viernes";
     SiNo
      si (dia = 6) Entonces
       Escribir "Sábado";
      SiNo
       si (dia = 7) Entonces
        Escribir "Domingo";
       SiNo
        Escribir "Día inválido";
       FinSi
      FinSi
     FinSi
    FinSi
   FinSi
  FinSi
 FinSi
 
FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman




17. Hacer un algoritmo en Pseint donde se ingrese una hora y nos calcule la hora dentro de un segundo.

Proceso Hora
 Definir hh, mm, ss Como Entero;
 
 Escribir "Ingresa hh, mm, ss";
 Leer hh;
 Leer mm; 
 Leer ss;
 
 si (hh < 24 y mm < 60 y ss < 60) Entonces
  ss <- ss + 1;
  si (ss = 60) Entonces
   ss <- 0;
   mm <- mm + 1;
   si (mm = 60) Entonces
    mm <- 0;
    hh <- hh + 1;
    si (hh = 24)Entonces
     hh <- 0;
    FinSi
   FinSi
  FinSi
 FinSi
 
 Escribir hh, " : ", mm, " : ", ss, " : ";
 
FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman




18. Hacer un algoritmo en Pseint para una empresa se encarga de la venta y distribución de CD vírgenes. Los clientes pueden adquirir los artículos (supongamos un único producto de una única marca) por cantidad. Los precios son:

  • $10. Si se compran unidades separadas hasta 9.
  • $8. Si se compran entre 10 unidades hasta 99.
  • $7. Entre 100 y 499 unidades.
  • $6. Para mas de 500 unidades.

La ganancia para el vendedor es de 8,25 % de la venta. Realizar un algoritmo en Pseint que dado un número de CDs a vender calcule el precio total para el cliente y la ganancia para el vendedor.

Proceso VentaCD
 Definir ventas,total Como Entero;
 total <- 0;
 Escribir '¿Cuántos Cds vendió?';
 Leer ventas;
 Si (ventas<=9) Entonces
  total <- ventas*10;
 SiNo
  Si (ventas<=99) Entonces
   total <- ventas*8;
  SiNo
   Si (ventas<=499) Entonces
    total <- ventas*7;
   SiNo
    Si (ventas>499) Entonces
     total <- ventas*6;
    FinSi
   FinSi
  FinSi
 FinSi

 Escribir 'Total a pagar por el cliente: ',total;
 Escribir 'Ganancias del vendedor: ',total*0.0825;
 
FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman




19. Hacer un algoritmo en Pseint para una heladería se tienen 4 tipos de empleados ordenados de la siguiente forma con su número identificador y salario diario correspondiente:

  1. Cajero (56$/día).
  2. Servidor (64$/día).
  3. Preparador de mezclas (80$/día).
  4. Mantenimiento (48$/día).

El dueño de la tienda desea tener un programa donde sólo ingrese dos números enteros que representen al número identificador del empleado y la cantidad de días que trabajó en la semana (6 días máximos). Y el programa le mostrará por pantalla la cantidad de dinero que el dueño le debe pagar al empleado que ingresó

Definir tipo,diaTrabajado,salario Como Entero;
 salario <- 0;
 
 Escribir 'Ingrese el identificador del empleado';
 Leer tipo;
 Escribir 'Ingrese los días trabajados';
 Leer diaTrabajado;
 
 Segun (tipo)  Hacer
  1:
   salario <- diaTrabajado*56;
  2:
   salario <- diaTrabajado*64;
  3:
   salario <- diaTrabajado*80;
  4:
   salario <- diaTrabajado*48;
  De Otro Modo:
   Escribir 'Tipo no válido';
 FinSegun
 
 Escribir 'La cantidad a pagar es: ',salario;
 
FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman





20. Hacer un algoritmo en Pseint que que lea 4 números enteros positivos y verifique y realice las siguientes operaciones:

  1. ¿Cuántos números son Pares?
  2. ¿Cuál es el mayor de todos?
  3. .
  4. Si el tercero es par, calcular el cuadrado del segundo.
  5. Si el primero es menor que el cuarto, calcular la media de los 4 números.
  6. Si el segundo es mayor que el tercero, verificar si el tercero esta comprendido entre los valores 50 y 700. Si cumple se cumple la segunda condición, calcular la suma de los 4 números.

Proceso CuatroNumeros

 Definir a,b,c,d Como Entero;
 Definir pares,grande Como Entero;
 Definir promedio Como Real;
 pares <- 0;
 promedio <- 0;
 grande <- 0;
 
 Escribir 'ingresa cuatro números';
 Leer a,b,c,d;
 
 Si (a MOD 2=0) Entonces
  pares <- pares+1;
 FinSi
 
 Si (b MOD 2=0) Entonces
  pares <- pares+1;
 FinSi
 
 Si (c MOD 2=0) Entonces
  pares <- pares+1;
 FinSi
 
 Si (d MOD 2=0) Entonces
  pares <- pares+1;
 FinSi
 
 Si (a>b Y a>c Y a>d) Entonces
  grande <- a;
 SiNo
  Si (b>c Y b>d) Entonces
   grande <- b;
  SiNo
   Si (c>d) Entonces
    grande <- c;
   SiNo
    grande <- d;
   FinSi
  FinSi
 FinSi
 
 Escribir 'La cantidad de número pares: ',pares;
 Escribir 'El mayor de todos es: ',grande;
 
 Si (c MOD 2=0) Entonces
  Escribir 'El cuadrado del segundo es: ',b*b;
 FinSi
 
 Si (a<d) Entonces
  Escribir 'El promedio de todos los números es: ',(a+b+c+d)/4;
 FinSi
 
 Si (b>c) Entonces
  Si (c>=50 Y c<=700) Entonces
   Escribir 'El tercer número está comprendido entre 50-700';
   Escribir 'La suma de los cuatro números es: ',a+b+c+d;
  SiNo
   Escribir 'El tercer número no está comprendido entre 50-700';
  FinSi
 FinSi
 
FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman





No hay comentarios