13. Algoritmos || Ejercicios estructuras selectivas Pseint


Estos serán algunos ejercicios de algoritmos hechos en Pseint que espero luego les ayuden a Aprender a programar.

Ejercicios algoritmos Pseint






1. Hacer un algoritmo en Pseint que lea un número por el teclado y determinar si tiene tres dígitos.

Proceso NumeroTresDigitos
 Definir x Como Entero;
 Escribir "Ingrese un número";
 Leer x;
 
 si (x > 100 y x < 999) entonces
  Escribir "El número ",x," tiene tres dígitos";
 SiNo
  Escribir "El número ",x," no tiene tres dígitos";
 FinSi
 
FinProceso 


Diagrama de flujo




Diagrama Nassi-Shneiderman




2. Hacer un algoritmo en Pseint que lea un número entero por el teclado y determinar si es negativo.

Proceso NumeroNegativo
 Definir x Como Entero;
 Escribir 'Ingrese un número';
 Leer x;

 Si (x < 0) Entonces
  Escribir 'El número ',x,' es negativo';
 SiNo
  Escribir 'El número ',x,' no es negativo';
 FinSi

FinProceso


Diagrama de flujo




Diagrama Nassi-Shneiderman




3. Hacer un algoritmo en Pseint que lea un número y determinar si termina en 4.

Proceso Numero4
 Definir num Como entero;
 
 Escribir 'Ingrese un número';
 Leer num;
 
 Si (num mod 10 = 4) Entonces
  Escribir "El número termina en 4";
 SiNo
  si(num mod 10 = -4) entonces
   Escribir "El número termina en 4";
  SiNo
   Escribir "El número no termia en 4";
  finsi
 FinSi
 
FinProceso 


Diagrama de flujo





Diagrama Nassi-Shneiderman




4. Hacer un algoritmo en Pseint que lea tres números enteros y los muestre de menor a mayor.

Proceso MenorAMayor
 Definir xx, yy, zz Como Entero;
 Escribir 'Ingrese tres números';
 Leer xx;
 Leer yy;
 Leer zz;
 
 si (xx < yy y xx < zz) entonces
  si (yy < zz)
   Escribir xx," ", yy, " ", zz;
  SiNo
   Escribir xx," ", zz, " ",yy;
  FinSi
 FinSi
 
 si (yy < xx y yy < zz) Entonces
  si (xx < zz) Entonces
   Escribir yy," ", xx," ", zz;
  SiNo
   Escribir yy," ", zz," ", xx;
  FinSi
 FinSi
 
 si (zz < xx y zz < yy) Entonces
  si (xx < yy)
   Escribir zz," ", xx," ", yy;
  SiNo
   Escribir zz," ", yy," ", xx;
  FinSi
 FinSi
 
FinProceso


Diagrama de flujo





Diagrama Nassi-Shneiderman




5. Hacer un algoritmo en Pseint para una tienda de zapatos que tiene una promoción de descuento para vender al mayor, esta dependerá del número de zapatos que se compren. Si son más de diez, se les dará un 10% de descuento sobre el total de la compra; si el número de zapatos es mayor de veinte pero menor de treinta, se le otorga un 20% de descuento; y si son más treinta zapatos se otorgará un 40% de descuento. El precio de cada zapato es de $80.

Proceso TiendaZapato
 Definir xx,monto Como Entero;
 monto <- 0;
 
 Escribir 'Ingrese los datos de la compra';
 Escribir "Zapatos comprados";
 Leer xx;
 monto <- xx * 80;
 
 si (xx < 10) entonces
  Escribir "El monto total a pagar es: ", monto;
 SiNo
  si(xx < 20) entonces
   Escribir "El monto total a pagar es: ", monto - (monto * 0.1);
   // monto * .01 representa el descuento
  sino 
   si(xx < 30) Entonces
    Escribir "El monto total a pagar es: ", monto - (monto * 0.2);
    // monto * .02 representa el descuento
   SiNo
    Escribir "El monto total a pagar es: ", monto - (monto * 0.4);
    // monto * .04 representa el descuento
   FinSi
  FinSi
 FinSi
 
FinProceso


Diagrama de flujo





Diagrama Nassi-Shneiderman





7 comentarios:

  1. Un Padre millonario tenía tres hijos: Karina, Josué y Mercedes. Al morir dejó la siguiente herencia: A Josué le dejó 2/3 de lo que le dejó a Karina. A Karina le dejó 1/4 de su fortuna. A Mercedes le dejo la mitad de lo que le dejó a Josué. Preparar un algoritmo para darle la suma a repartir y muestre cuanto le tocó a cada uno, luego subir la imagen del pseudocódigo, diagrama de flujo y cuadro de ejecución.

    ResponderEliminar
    Respuestas
    1. Proceso Herencia
      Definir n,k,j,m Como Real
      Escribir "¿Cuánto es la herencia?"
      Leer n
      k <- n/4
      j <- k*2/3
      m <- J/2
      EScribir "a Karina le dejó : " k
      EScribir "a Josué le dejó : " j
      EScribir "a Mercedes le dejó : " m
      FinProceso

      Eliminar
  2. quiero hacer un algoritmo que simule una maquina traga monedas

    ResponderEliminar

  3. Tres hermanos: José, Martín y Abel , recibirán una herencia en dólares que será repartida entre ellos proporcionalmente, de acuerdo a su edad, diseñe un algoritmo que calcule el valor que le corresponde a cada uno

    ResponderEliminar
  4. como se desarrollaria este algoritmo: Dado el ancho, largo y alto de una caja, calcular el volumen y la cantidad de papel (en cm2) necesario para cubrirla.

    ResponderEliminar
  5. Como se haria el siguiente algoritmo? : Dados los factores primos de un Numero N, ¿Es posible encontrar(si hay) dos numeros a,b tal que a^2 + b^2 = ?

    ResponderEliminar
  6. Podrían ayudarme con este ejercicio?
    Es para un parcial de la universidad. Ingrese una cantidad mayor que 100, validela.
    Ese valor representa una herencia que se desea distribuir de forma variables entre herederos, no se sabe cuantos herederos llegarán

    ResponderEliminar